Infiniti JX Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My 2013 AWD JX has a noise in the front end when making a slow sharp turn. Steering fells like the front tires are slipping and the anti-lock is kicking in. Dealer claims it is a software issue with AWD. Does anyone with AWD have this problem? I also have a slight odor of burning antifreeze. Dealer can't find anything. Does anyone else have this problem?
 

·
Premium Member
Joined
·
467 Posts
How many miles? The smell could just be the coating on the exhaust components burning off, or some catalyst (although that doesn't usually smell like antifreeze). Is the odor outside or inside the car?
 

·
Registered
Joined
·
524 Posts
My 2013 AWD JX has a noise in the front end when making a slow sharp turn. Steering fells like the front tires are slipping and the anti-lock is kicking in. Dealer claims it is a software issue with AWD. Does anyone with AWD have this problem? I also have a slight odor of burning antifreeze. Dealer can't find anything. Does anyone else have this problem?
I have AWD and don't have a strange noise, slipping tires.

If the antifreeze is burning, it's likely won't pool under the car making it harder to find. Keep an eye on the overflow reservoir and report this to the dealership.
 

·
Registered
Joined
·
118 Posts
Ive noticed the slippage also turning out of my driveway...no smells though. I also noticed that when going over a speed bump, a little clank or bumping sound. Like something is a little lose or something...

Im due to take it it for the fuel recall, Ill have the dealership check it then.

Keep us posted if you find something!
 

·
Registered
Joined
·
6 Posts
*Bump*
my JX35 is 8 months old and has 8K miles (12K KM) on it - and I still smell this!! I also still have the judder... Supper unimpressed with Infiniti, this will certainly be my one and only purchase of their products...

Anyone had a resolution on the burning coolant / antifreeze problem?
 
1 - 5 of 5 Posts
Top